Движок для портативной семантической медив вики

Содержание

Совместимость версий ПО для MW и SMW

ПО PHP MariaDB Perl 5.32.1
XAMP 7.4.27-2 7.4.27 10.4.22 5.32.1
XAMP 8.0.15-0 8.0.15 10.4.22 5.32.1
XAMP 8.1.2-0 8.1.2 10.4.22 5.32.1
Mediawiki 1.37.2 PHP 7.3.19/7.4.3+ MySQL 5.5.8+/10.4.18 Текст ячейки
Mediawiki 1.35.6 LTS PHP 7.3.19+ MySQL 5.5.8+/10.4.18 Текст ячейки
SMW 4.1.x в разработке 7.4.0 - 7.4.x Текст ячейки MediaWiki 1.35
SMW 4.0.0 7.3.0 - 7.4.x MySQL 5.5.8+ MediaWiki 1.35-37/ PCRE 8.33(scributino)/8.38 (SMW)
SMW 3.2.3 7.1.0 - 7.4.x MySQL 5.5.8+/10.1.48-MariaDB MediaWiki 1.31-35

Выбор: XAMP 7.4.27 + MW 1.35 LTS + SMW 4.0 (PHP - 7.4.27)

MediaWiki 1.37 requires PHP 7.3.19 or later, or PHP 7.4.3 or later, and the following PHP extensions:

Support for PHP 8.0 is not yet complete.

MySQL 5.5.8 /MariaDB is the recommended DBMS.

Необходимые расширения и версии ПО для них

Расширения PHP для mw 1.35

following PHP extensions:

см. также